Установить параметр СКД 1С  


0

 Если параметр СКД присутствует во вкладке "Параметры", то для его заполнения используем код:

&НаСервере
Процедура УстановитьПараметрВоВкладкеПараметры(НазваниеПараметра, ЗначениеПараметра)
ЭтаФорма.Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.УстановитьЗначениеПараметра(НазваниеПараметра, ЗначениеПараметра);
КонецПроцедуры

если же параметр СКД задан в запросе, но его нет во вкладке "Параметры", то для заполнения параметра используем следующий код:

&НаСервере
Процедура УстановитьПараметрСКД(НазваниеПараметра, ЗначениеПараметра)Параметры = КомпоновщикНастроек.Настройки.ПараметрыДанных;
Параметр = Параметры.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных(НазваниеПараметра));
Если Параметр <> Неопределено Тогда Параметр.Значение = ЗначениеПараметра;
Параметр.Использование = Истина; КонецЕсли;КонецПроцедуры
Отредактировано:7 месяцев  назад
 
  
Работает

Пожалуйста, Вход или Зарегистрироваться


Рейтинг@Mail.ru
Яндекс.Метрика
Здесь находится аттестат нашего WM идентификатора 739402762981
Проверить аттестат